Opened 12 years ago

Last modified 11 years ago

#31 reopened Bug

Problem with diacritical characters when editing

Reported by: girgen@… Owned by: somebody
Priority: major Milestone:
Component: Application Version: v4.0.5
Severity: Serious Keywords:
Cc: Operating System: Linux
OS Version:


When typing/editing emails, diacrtical (i.e. non-ASCII) characters are not handled correctly. They show up as dotted boxes when typing, and there seems to be som sort of double conversion going on. When running with my standard locale, LC_ALL=sv_SE.ISO8859-1, I get one box per character, but when running with a UTF-8 locale (needed for proper timestamp display, see separate bug report) I get two boxes for each character.

The email sent seems to have been converted at least twice from from single-byte to multibyte chars:

Content-Type: text/plain; charset=utf-8; format=flowed
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Hej Martin!

Jag jobbar p=EF=BF=83=EF=BE=A5 detta, men kan inte svara =
=EF=BF=83=EF=BE=A4nnu, f=EF=BF=83=EF=BE=B6rs=EF=BF=83=EF=BE=B6ker=20
=EF=BF=83=EF=BE=A5terkomma imorgon.


If you need more input, I'll be happy to give it to you. I run Mulberry on FreeBSD under Linux emulation. It has always worked fine, this shouldn't be the problem?


Change History (4)

comment:1 Changed 12 years ago by girgen@…

This is the same bug as described in #75. Umlauts == diacritical characters.

comment:2 Changed 12 years ago by daboo@…

  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 12 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

With 4.0.6, it works when typing, but not when using copy-paste from another mail.

comment:4 Changed 11 years ago by daboo

Milestone Release deleted

Note: See TracTickets for help on using tickets.